Написать программу и нарисовать блок-схему 1. ввести с клавиатуры целое положительное число, если число заканчивается на 2, то увеличить его на 3 и вывести на экран. 2. ввести с клавиатуры целое положительное число, если число делится на 8, то увеличить его в 3 раза и вывести на экран, указав, что оно делиться на 8. 3. определите, имеется ли среди заданных целых чисел a, b, c хотя бы одно чётное. 4. ввести с клавиатуры целое положительное число, если число если число заканчивается на 6, то увеличить его на 3 и вывести на экран. 5. даны три числа. найти наименьшее из них. 6. ввести целое число и найти сумму его цифр. 7. найти сумму первой и последней цифр любого целого положительного числа 8. найти удвоенное произведение цифр числа, вводимого с клавиатуры.
var a,b,c,d,e,f,r,x,y,z:real;
begin
writeln('d, e, f:');
readln(d,e,f);
write('r = ');
readln(r);
x:=d*pi/180;
y:=e*pi/180;
z:=f*pi/180;
a:=2*r*sin(x);
b:=2*r*sin(y);
c:=2*r*sin(z);
writeln('a = ',a:5:2,' b = ',b:5:2,' c = ',c:5:2);
end.
Пример:
d, e, f:
90 60 30
r = 2.5
a = 5.00 b = 4.33 c = 2.50
2)
var a,b,c,d:integer;
begin
writeln('a, b, c, d:');
readln(a,b,c,d);
if a+c>150
then writeln('a+c = ',a+c,' a = ',a,' b = ',b,' c = ',c,' d = ',d);
end.
Пример:
a, b, c, d:
72 18 94 25
a+c = 166 a = 72 b = 18 c = 94 d = 25
Целая часть от деления
293 div 8 = 36
36 div 8 = 4
4 div 8 = 0
0 div 8 = 0
Остаток от деления
293 mod 8 = 5
36 mod 8 = 4
4 mod 8 = 4
0 mod 8 = 0
Остаток от деления записываем в обратном порядке. Получаем целую часть числа в 8-ой системе счисления: 0445
293 = 0445
Для перевода дробной части числа последовательно умножаем дробную часть на основание 8. В результате каждый раз записываем целую часть произведения.
0.125*8 = 1 (целая часть 1)
0*8 = 0 (целая часть 0)
0*8 = 0 (целая часть 0)
0*8 = 0 (целая часть 0)
1000
Получаем число в 8-ой системе счисления: 1000
0.125 = 0.10008
В итоге получаем число: 0445.10008
ответ: 293.125=0445.10008
Решение было получено и оформлено с сервиса:
Перевод чисел онлайн