В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
EHOT229
EHOT229
23.02.2021 02:51 •  Информатика

Написать программу, которая 30 раз выводит в переменную, а случайные числа, и суммирует те из них, которые больше, чем 40. диапазон чисел до 55

Показать ответ
Ответ:
elena563
elena563
26.05.2020 16:45

Program mmm;

Var a : real;  

var i: integer;  

s: real;

begin

s:=0;

Randomize;

For i := 1 To 30 Do

Begin

   a := random*100-45;

   writeln(a:6:2) ; //выписываем сгенерированные числа, необязательно

if   a>40 then

 s:=s+a;

 End;

writeln(s:6:2) ;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота