В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу, которая будет сортировать массив из 20 случайных чисел, из диапазона от -5 до 5 по следующим правилам: 1- убрать нули и повторяющиеся элементы. 2- оставшиеся элементы отсортировать а) первую половину по возрастанию б) вторую половину по убыванию. Сделать на Pascal

Показать ответ
Ответ:
nintendo161
nintendo161
20.03.2021 15:10

const n=20; m=10;

var  

a:array[1..n] of integer;

k:array[0..m-1] of integer;

i,j,max:integer;

begin

writeln('Исходный массив:');

for i:=1 to n do

begin

a[i]:=random(m);

write(a[i],'  ');

end;

writeln;

for j:=0 to m-1 do k[j]:=0;

for i:=1 to n do k[a[i]]:=k[a[i]]+1;

max:=0;

for j:=1 to m-1 do

 if k[j]>k[max] then max:=j;

writeln('Самый часто встречающийся элемент: ',max);

writeln('Встречается в массиве ',k[max],' раз(а)');

end.

Объяснение:Пример:

Исходный массив:

1  1  8  8  6  2  3  8  8  9  5  2  6  9  8  7  3  9  7  9  

Самый часто встречающийся элемент 8

Встречается в массиве 5 раз(а)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота