В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zadojnov09
zadojnov09
09.09.2021 00:59 •  Информатика

Написать программу , которая должна производиться действия над векторами и матрицами, оформленными в виде функций. должна быть генерация векторов и матриц произвольного размератакже должны быть: 1)вектор * на число пи 2)вектор * на матрицу 3)матрица * на число пи 4)определение длины векторана языке с​

Показать ответ
Ответ:
Regardless777
Regardless777
25.03.2021 20:51

Решение Pascal

Delphi/Pascal

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

 

Решение C

C

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
alice1607
alice1607
31.03.2023 04:25

Жобалаудың барысын басқаруды жақсарту мақсатында әрбір кезең нақтыланады, яғни кезеңдерге бөлінеді.

Автоматтандырылған жүйені құрудың 4 кезеңі-Жұмыс сипаты, оның нәтижесі немесе орындаушылардың мамандануы бойынша анықталатын АЖ құру сатысының бір бөлігі.

АЖ құру кезеңдерінің мазмұны ГОСТ 34.601-90 1-қосымшасында регламенттелген.

"АС-қа қойылатын талаптарды қалыптастыру" 1-ші сатысында "объектіні тексеру және АС құру қажеттілігінің негіздемесі" 1-ші кезеңінде объект және оның қызметінің түрлері туралы деректер жинауды жүргізеді. Объектінің және оның құрамдас бөліктерінің жұмыс істеу сапасын бағалайды. Автоматтандыру құралдарының көмегімен шешуге болатын мәселелер мен міндеттерді анықтайды. Жүйені құрудың орындылығын бағалаудың техникалық-экономикалық, әлеуметтік және басқа да түрлерін береді.

"АС-қа пайдаланушылардың талаптарын қалыптастыру" 2-ші кезеңінде АС-қа қойылатын талаптарды қалыптастыру үшін бастапқы деректерді дайындайды, пайдаланушылардың талаптарын қалыптастырады және ресімдейді. Автоматтандыру объектісінің сипаттамасы, жүйені әзірлеуге, іске қосуға және пайдалануға рұқсат етілген шығындар, күтілетін нәтиже, жүйені құру және жұмыс істеу шарттары сияқты құжаттарды дайындайды .

3-ші кезеңде" орындалған жұмыс туралы есепті және жүйені (тактикалық-техникалық тапсырма — ТТТ) әзірлеуге өтінімді жасау " 1-ші кезеңде орындалған жұмыстар туралы есепті және ТТТ әзірлеуге өтінімді немесе мазмұны бойынша ұқсас басқа құжатты ресімдейді.

"АС тұжырымдамасын әзірлеу" 2-ші сатысында "объектіні зерделеу" 1-ші кезеңінде автоматтандыру объектісін егжей-тегжейлі зерделейді.

"Қажетті ғылыми-зерттеу жұмыстарын жүргізу" (ҒЗЖ) 2-кезеңінде пайдаланушылардың барлық талаптарын іске асыру мүмкіндігін бағалау және жолдарды іздестіруді орындайды, ҒЗЖ бойынша есептерді ресімдейді және бекітеді.

"АС тұжырымдамасының нұсқаларын әзірлеу және пайдаланушының талаптарын қанағаттандыратын АС тұжырымдамасының нұсқасын таңдау "3-кезеңінде АС тұжырымдамасының, оларды іске асыру жоспарлары мен ресурстарының баламалы нұсқаларын әзірлеуді, артықшылықтары мен кемшіліктерін бағалауды жүргізеді және бірнеше әзірленген оңтайлы нұсқадан таңдайды. Жүйені қабылдау тәртібі мен шарттарын, оның тиімділігін айқындайды.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота