В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gtufifk
gtufifk
08.07.2022 02:12 •  Информатика

Написать программу, которая генерирует. массив из n целых чисел и выводит на экран количество четных элементов.

Показать ответ
Ответ:
alinabiychinska
alinabiychinska
04.04.2019 22:20

java

import java.util.random;

public class myapp{

  public static void main (string {

    random rand = new random();

    int n = rand.nextint(50);

    int [] arr = new int[n];

    for(int i = 0; i < n; i++) {

      int j = rand.nextint(50);

      arr[i] = j;

    }

    for( int i = 0; i < n; i++) {

      if ( arr[i] % 2 == 0 ) {

        system.out.print(arr[i] + " ");

      }

    }

  }

}

pascal

program myapp;

var

  i, n , j: integer;

  arr: array of integer;

begin

randomize;

n : = random(50);

setlength(arr, n);

for i: = 0 to n do

  begin

    j: = random(50);

    arr[i]: = j;

  end;

for i: = 0 to n do

  begin

    if( arr[i] mod 2 = 0 ) then

      begin

        write(arr[i], ' ');

      end;

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота