Написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет" const n=20; var a: array [1..n] of integer; i,j,max: integer; begin for i: = 1 to n do readln(a[i]); max: =99; j: =a[i]; for i: = 1 to n do if (j> 99) and (j< 999) and (j mod 9 < > 0) and (j> max) then max: =j; if max> 99 then writeln (max) else writeln ('no'); readln; end. программа проверяет только последнее число, а не все 20. где ошибка?
N=20;
var
a:array [1..N] of integer;
i,j,max,k:integer;
begin
max:=99;
for i:= 1 to N do
begin
readln(a[i]);
j:=a[i];
for k:= 1 to N do
begin
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
end;
end;
if max>99 then writeln (max) else writeln ('no');
end.