Написать программу, которая определяет, попадает ли точка с введенными с клавиатуры координатами (x,y) в заштрихованную область. C++ Не нужно писать целую программу, хотя бы условия для каждой четверти. Заранее благодарю
1) r=187,5 a=9 d=63 2) var a,b,c,d,e:integer; sr:real; begin writeln('Оценка за первый опрос'); read(a); writeln('Оценка за второй опрос'); read(b); writeln('Оценка за третий опрос'); read(c); writeln('Оценка за четвертый опрос'); read(d); writeln('Оценка за пятый опрос'); read(e); sr:=(a+b+c+d+e)/5; writeln('Среднее значение равно ',sr); end. 3)var a,b,d, dengi,ostatok: integer; begin writeln('Количество денег у человека'); read(dengi); writeln('Стоимость перчаток'); read(a); writeln('Стоимость портфеля'); read(b); writeln('Стоимость галстука'); read(d); ostatok:=dengi-a-b-d; writeln('Остаток от изначальной суммы равен ',ostatok); end.
Const n=10; m=10; var a:array [1..n,1..m] of integer; i,j,min,x1,y1,max,x2,y2:integer; begin for i:=1 to n do begin for j:=1 to m do begin a[i,j]:=random(21)-10; write (a[i,j]:4); end; writeln; end; min:=a[1,1]; max:=a[1,1]; x1:=1; x2:=1; y1:=1; y2:=1; for i:=1 to n do for j:=1 to n do if a[i,j]<min then begin min:=a[i,j]; x1:=i; y1:=j; end else if a[i,j]>max then begin max:=a[i,j]; x2:=i; y2:=j; end; writeln ('Минимальный элемент A[',x1,',',y1,']=',min); writeln (',Максимальный элемент A[',x2,',',y2,']=',max); end.
a=9
d=63
2) var a,b,c,d,e:integer;
sr:real;
begin
writeln('Оценка за первый опрос');
read(a);
writeln('Оценка за второй опрос');
read(b);
writeln('Оценка за третий опрос');
read(c);
writeln('Оценка за четвертый опрос');
read(d);
writeln('Оценка за пятый опрос');
read(e);
sr:=(a+b+c+d+e)/5;
writeln('Среднее значение равно ',sr);
end.
3)var a,b,d, dengi,ostatok: integer;
begin
writeln('Количество денег у человека');
read(dengi);
writeln('Стоимость перчаток');
read(a);
writeln('Стоимость портфеля');
read(b);
writeln('Стоимость галстука');
read(d);
ostatok:=dengi-a-b-d;
writeln('Остаток от изначальной суммы равен ',ostatok);
end.
var a:array [1..n,1..m] of integer;
i,j,min,x1,y1,max,x2,y2:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write (a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
max:=a[1,1];
x1:=1;
x2:=1;
y1:=1;
y2:=1;
for i:=1 to n do
for j:=1 to n do
if a[i,j]<min then
begin
min:=a[i,j];
x1:=i;
y1:=j;
end else
if a[i,j]>max then begin
max:=a[i,j];
x2:=i;
y2:=j;
end;
writeln ('Минимальный элемент A[',x1,',',y1,']=',min);
writeln (',Максимальный элемент A[',x2,',',y2,']=',max);
end.