В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
123456782121
123456782121
22.09.2022 03:39 •  Информатика

Написать программу , которая получает от пользователя три числа – стороны треугольника , а компьютер вычисляет и выводит на экран периметр этого треугольника . Пример : Пользователь вводит : 12 7 Компьютер выводит : Площадь треугольника равна 42​. в Pascale abc

Показать ответ
Ответ:
Karukart
Karukart
27.02.2022 20:35

С развитием Интернета у библиотек появилось больше возможностей узнать мнение читателей о работе учреждения и сотрудников: анкеты размещаются в социальных сетях, на официальном сайте, на страницах блога.

Рассказываем, как оформить анкету, чтобы читатели смогли быстро и без трудностей ее заполнить, а также приводим в пример несколько онлайн-ресурсов, которые позволят быстро составить анкету и распространить ее среди пользователей.

Библиотекари регулярно проводят среди своих читателей соцопросы, как правило, для того чтобы выяснить качество предоставляемых услуг, а также составить статистику читателей: пол, возраст, профессия и многие другие показатели. Это составить объективное представление о своих читателях, какие книги больше всего пользуются спросом, а также определить свое место на рынке библиотечно-информационных услуг.

Соцопросы значительно упрощают процесс подготовки очередного мероприятия или творческой встречи. Библиотекари могут определить степень заинтересованности читателей в тематике предстоящего мероприятия.

Начало работы

В первую очередь необходимо определить четкую задачу, которую будет выполнять ваш опрос. От четко поставленной цели напрямую зависит содержание анкеты: вопросы, варианты ответов, заключение.

Шапка. В начале анкеты обязательно должно быть указано ее название — в «шапке» или в обращении к респонденту. Название постарайтесь придумать короткое – 3–4 слов будет достаточно.

Преамбула. После «шапки» следует преамбула, или вступительное слово, где следует поприветствовать респондента и вкратце описать, что от него требуется. Также в приветствии рекомендуется предупредить о том, что опрос является анонимным, а личные данные не уйдут к третьим источникам.

Окончание. В конце анкеты не забудьте поблагодарить респондента за уделенное время.

Составляем вопросы для анкеты

Все вопросы в анкете можно разделить на две категории: прямые и косвенные. Например, вопрос «Нравится ли Вам профессия библиотекаря?» является прямым, поскольку его содержание и интересы исследователя совпадают, а студенты или преподаватели не обладают компетенциями ответить на него.

В косвенных вопросах эти два показателя расходятся. Например, вопрос «Согласны ли Вы, что профессия библиотекаря является одной из самых интересных?» относится к более широкому кругу респондентов, вне зависимости от профессии. Однако злоупотреблять таким типом вопросов не следует.

По наличию вариантов ответов вопросы могут быть разделены на несколько категорий:

1. закрытые — предлагается выбрать всего один вариант ответа.

2. полузакрытые — можно выбрать несколько вариантов ответа.

3. открытые — респондент может самостоятельно выбрать формат ответа, без подсказок (вариантов ответа).

В зависимости от выполняемых функций вопросы бывают контрольными и основными. Если основные вопросы несут в себе прямой смысл, то контрольные служат скорее для проверки искренности респондента. Они задаются, как правило, уже после того, как был дан ответ на основной вопрос.

Составляем структуру и порядок вопросов

Следите за объемом. Количество вопросов зависит от самого исследования. Однако следите, чтобы анкета не была слишком большой, — не у каждого респондента много свободного времени, которое он может уделить вашей анкете.

Соблюдайте логику. Грамотно выстроенная логика не вызовет лишних вопросов у отвечающего и не потребует дополнительного объяснения. Особенно за логикой следует следить в онлайн-анкетировании, где анкеты поддерживают такую возможность, как развитие дальнейшего опроса в зависимости от выбранного варианта ответа.

Выстраивайте сложность по возрастанию. Сначала разместите простые вопросы, ответы на которые не вызовут у респондента трудностей, затем — более сложные. Не забывайте при этом оставлять пустые поля для ответа респондента.

Будьте краткими. Вопросы должны быть четкими и восприниматься однозначно: уберите лишние слова, не влияющие на смысл, проверьте логическую последовательность.

Следите за целостностью блоков. Не следует переносить часть вариантов ответа на другую страницу — это попросту неудобно. Вряд ли кто-то будет сверять информацию на разных страницах, он либо пропустит вопрос, либо попросту не увидит оставшуюся часть вариантов. Соответственно, это негативно повлияет на результаты. Если вопрос не помещается на страницу, разумней будет его целиком перенести на другую страницу.

Проверяйте анкету после публикации. После того как вы опубликовали анкету, станьте первым респондентом своего же опроса: перейдите по ссылке, заполните все данные, отправьте результаты на электронную почту. Вполне возможно, что вы могли упустить важные детали, и чем раньше вы поправите неточности, тем лучше.

Объяснение:

вот как то так, но никак иначе

0,0(0 оценок)
Ответ:
helpmepls1234566
helpmepls1234566
05.11.2021 04:55

Более простой вариант

from datetime import timedelta

 

music = {"mus1": 4.24,

       "mus2": 2.50,

       "mus3":  2.05}

time = timedelta(minutes=0, seconds=0)

maxcount = int(input("Сколько песен выбрать?: ")) + 1

count = 1

while 1:

       try:

               name = str(music[input(f"Название {count} песни: ")]).replace(".", " ").split()

               time = time + timedelta(minutes=int(name[0]), seconds=int(name[1]))

               count += 1

       except:

               print("Такой песни нету!")

               break

       if count == maxcount:

               print(f"Общее продолжительность песен: {int(time.total_seconds()%3600) // 60}.{int(time.total_seconds()%3600) % 60}")

               break

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота