В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
asia1406
asia1406
03.02.2023 03:10 •  Информатика

Написать программу,которая считает длину строки,введенной с клавиатуры и вывести её без третьего символа.

Показать ответ
Ответ:
Прша
Прша
03.10.2020 03:10
Var        str: string;        i, count: integer;begin        write('Your string: ');        readln(str);        i := length(str);        if i > 0 then begin                count := 1;                while i > 0 do begin                        if str[i] = ' ' then                                count := count + 1;                        i := i - 1;                end;        end        else                count := 0;                delete(str,3,1);        writeln('Number of words: ', count);         writeln(str);readln;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота