В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lolo105
lolo105
13.05.2021 14:27 •  Информатика

Написать программу, которая требует ввода времени дня и, в зависимости от введённого значения, желает доброго утра, доброго дня, доброго вечера или спокойной ночи. среда програмирования: pascal abc.net

Показать ответ
Ответ:
nastyaozernova
nastyaozernova
25.09.2020 20:50
Program blablsbls;
var
time: integer;
begin
writeln('Введите текущий час!')
readln(time);
if time >= 7 and time < 11 then writeln('Доброе утро!');
if time >= 11 and time < 18 then writeln('Добрый день!');
if time >= 18 and time < 24 then writeln('Добрый вечер!');
if time >= 0 and time < 7 then writeln('Спокойной ночи!');
end.

Как-то так, если мне память на счет синтаксиса не изменяет.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота