В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rulmich1203p0dlzb
rulmich1203p0dlzb
15.11.2021 08:53 •  Информатика

Написать программу, которая вычисляет факториал числа, введенного с клавиатуры, используя цикл с постусловием. язык - pascal

Показать ответ
Ответ:
Nikita45Nikita45
Nikita45Nikita45
07.07.2020 19:16
var
  y: System.uint64; //Большая цЫфра же и положительная
  x, i: byte; //Нет смысла большие числа брать слишком, переполнение будет

begin
  readln(x); //Принимаем число...
  y := 1;
  i := 1;
  repeat
    y *= i; //...и умножаем такое-то количество раз
    i += 1;
  until (i > x);
  if (y = 0) then //Выводим, предусмотрев переполнение
    writeln('Слишком большая цЫферка')
  else
    writeln(y);
end.

Int64 - это то же самое, что LongInt, а Uint64 (unsign long int) - длинное число без знака, при правильном использовании позволяет записывать в переменную числа, в 2 раза превышающие максимум Int64
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота