В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Devil536
Devil536
05.01.2021 23:06 •  Информатика

Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. сопротивления могут быть соединены последовательно или параллельно.

Показать ответ
Ответ:
TkAl06
TkAl06
05.07.2020 21:45
Program soprotiv; {Название программы} 
var r1, r2:real; {Задаем переменные} 
c:byte; 
begin {Начало программы} 
write ('Введите 1 сопротивление... '); {Вывод сообщения о вводе данных} 
readln (r1); {Ввод данных с клавиатуры} 
write ('Введите 2 сопротивление... '); {Вывод сообщения о вводе данных} 
readln (r2); {Ввод данных с клавиатуры} 
write ('Если соединение параллельное, то нажмите клавишу 1, если соединение последовательное - нажмите 0...'); {Вывод сообщения о вводе данных} 
readln (c); {Ввод данных с клавиатуры} 
if c=1 {условие} 
then writeln ('Сопротивление электрической цепи, соединенной параллельно=',(r1*r2)/(r1+r2)) {Вывод значения, при параллельном соединении} 
else writeln ('Сопротивление электрической цепи, соединенной последовательно=',(r1+r2)); {Вывод значения, при последовательном соединении} 
end. {Конец программы} 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота