Написать программу, которая вычисляет среднее арифметическое первых n членов последовательности 1, 3, 5, 7, …, n. Количество n задается во время работы программы.
Среди двухзначных чисел найдите и выведите на экран числа, сумма цифр которых делится на 13.
ответ:1, 3, 5, 7, ... - арифметическая прогрессия, в которой первый член a1=1 и разность d=7-5=5-3=3-1=2.
запишем формулу n члена прогрессии:
an=a1+d(n-1)=1+2n-2=2n-1, где n - номер члена последовательности.
Составляем программу:
var n,s,i: integer;
begin
readln(n);
s:=1;
for i:=2 to n do s:=s+2*i-1;
write('сумма: ',s);
end.
Объяснение: