В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nimfa48
Nimfa48
22.01.2022 02:29 •  Информатика

Напишите программу на языке паскаль. требуется выяснить, является ли введенное пользователем число совершенным. совершенным называется такое число, сумма делителей которого равна этому числу, если не учитывать в ней последний делитель-само заданное число. например, число "6" является совершенным
числом, поскольку оно имеет три делителя: 1, 2, 3 и при этом 1+2+3=6, то есть самому числу

Показать ответ
Ответ:
Mikhail55Rus
Mikhail55Rus
10.10.2020 03:46

var N,i,k:integer;

BEGIN

readln(N);

k:=0;

for i:=1 to N div 2 do

if (N mod i=0) then

k:=k+i;

if (k=N) then

writeln('Да') else

writeln('Нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота