Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Shoka63
22.12.2022 10:47 •
Информатика
Написать программу которая задает массив случайным образом и ищет минимальный элемент
Показать ответ
Ответ:
arina1271
04.10.2020 11:58
Const n=10;
var a:array[1..n] of integer;
min,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(51);
write(a[i],' ');
end;
writeln;
min:=a[1];
for i:=2 to n do
if a[i]<min then min:=a[i];
writeln('min = ',min);
end.
Пример:
26 23 27 25 35 8 40 17 43 23
min = 8
0,0
(0 оценок)
Популярные вопросы: Информатика
cerenkovvladimi
29.07.2022 06:50
Дано целое число. Если оно является положительным, то прибавить к нему 1 ; если отрицательным, то вычесть из него 4; если нулевым, то заменить его на 15. Вывести полученное число....
2006zahar2006
11.07.2021 04:48
AB ставить сноску айырмашылыгы...
ali0002
28.06.2021 08:05
Составить программу построения изображения с использованием процедуры house в pascal abc...
karamanilya
11.03.2021 22:19
Закодируй число 2020 и год своего рождения. (2008) ...
urokiiiii
28.12.2022 18:06
Выбери один неверный ответ. Что общего у команд КОПИРОВАТЬ и ВЫРЕЗАТЬ...
dbd2
06.05.2022 13:59
Придумать 3 высказывания и из них составить 3 конъюнкции и дизъюнкции Help me pls pls pls pls pls pls pls pls pls pls pls pls ...
ванюшаплай
11.05.2022 07:33
Программирование линейных алгоритмов. Урок 1 аниеэритмов.Вставь пропущенные слова.обычно вводятся с клавиатуры пользователем или определяются с оператора присваивания и необходимы...
hatira801
10.09.2022 12:35
Конденсатор состоит из трех металлических пластинок площадью 3 см каждая, разделенных между собой двумя слоями диэлектрика толщиной 0,05 мм с ε = 5 Внешние пластины соединены между...
blrikiog
10.09.2022 12:35
Дуже потрібно. До ть, будь ласка!...
умныйчеловеккслюблю
10.09.2022 12:35
Переведите на венгерский язык: На окне корзина....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a:array[1..n] of integer;
min,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(51);
write(a[i],' ');
end;
writeln;
min:=a[1];
for i:=2 to n do
if a[i]<min then min:=a[i];
writeln('min = ',min);
end.
Пример:
26 23 27 25 35 8 40 17 43 23
min = 8