В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
burgerface
burgerface
16.07.2021 14:10 •  Информатика

Написать программу, которая запрашивает дату рождения (день и месяц) и сообщает соответствующий знак зодиака на языке C++​

Показать ответ
Ответ:
dukamaksim6
dukamaksim6
28.08.2020 16:35

def pramougolnik(a, b):

  return (int(a) + int(b)) * 2

def treugolnik( a, b, c ):

  return int(a) + int(b) + int(c)

a = input("Введите ширину прямоугольника")

b = input("Введите высоту прямоугольника")

print("Периметр прямоугольника равен: ", pramougolnik(a, b))

a = input("Введите 1 сторону треугольника")

b = input("Введите 2 сторону треугольника")

c = input("Введите 3 сторону треугольника")

print("Периметр треугольника равен: ", treugolnik(a, b, c))

Объяснение:

Как мы знаем перимитр это сумма всех сторон фигуры, для нахождения перимитра прямоугольника мы суммируем все стороны прямоугольника но мы сократим это: вместо того чтобы писать P=a+b+c+d мы сократим это до P=(a+b)*2.

С треугольником тоже самое

Ещё при return мы должны возвращать число а не строку, если бы мы умножили строку было бы так:

a = "Привет!"

print(a*2)

Результат: Привет!Привет!

Из-за этого мы используем int() конвертируя "строковое число" в число

0,0(0 оценок)
Ответ:
frashthefrash
frashthefrash
17.01.2020 18:02

скрин

Объяснение:

7.

пока условие i <= 6 истинное (да) цикл выполняет действия:

S = S + i

i = i + 1

когда условие i <= 6 становится ложным (нет) цикл прекращается

S = 0     i = 0

i <= 6 (0 <= 6, да)

S = 0 + 0 = 0

i = 0 + 1 = 1

S = 0     i = 1

i <= 6 (1 <= 6, да)

S = 0 + 1 = 1

i = 1 + 1 = 2

S = 1     i = 2

i <= 6 (2 <= 6, да)

S = 1 + 2 = 3

i = 2 + 1 = 3

S = 3     i = 3

i <= 6 (3 <= 6, да)

S = 3 + 3 = 6

i = 3 + 1 = 4

S = 6     i = 4

i <= 6 (4 <= 6, да)

S = 6 + 4 = 10

i = 4 + 1 = 5

S = 10     i = 5

i <= 6 (5 <= 6, да)

S = 10 + 5 = 15

i = 5 + 1 = 6

S = 15     i = 6

i <= 6 (6 <= 6, да)

S = 15 + 6 = 21

i = 6 + 1 = 7

S = 21     i = 7

i <= 6 (7 <= 6, нет) - цикл прекращается

8.

цикл выполняет действия:

P = P * i

i = i + 2 (шаг равен 2 по условию)

пока условие i <= n истинное (да)

когда условие i <= n становится ложным (нет) цикл прекращается

n = 5     i = 1     P = 1

P = 1 * 1 = 1

i = 1 + 2 = 3

i <= n (3 <= 5 да)

n = 5     i = 3     P = 1

P = 1 * 3 = 3

i = 3 + 2 = 5

i <= n (5 <= 5 да)

n = 5     i = 5     P = 3

P = 3 * 5 = 15

i = 5 + 2 = 7

i <= n (7 <= 5 нет) - цикл прекращается

n = 5     i = 7     P = 15


7. Заполните трассировочную таблицу8. Заполните трассировочную таблицу, если шаг равен 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота