В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tesckep
Tesckep
09.04.2022 04:49 •  Информатика

Написать программу, которая запрашивает массив размерности N и выводит на
экран сам массив, а также наибольший и наименьший элементы массива. PascalABC

Показать ответ
Ответ:
mtv1007
mtv1007
26.12.2022 22:49
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
function FS(a,b:real):=0.5*a*b;
begin
  var a,b:real;
  Write('Катеты первого треугольника: '); Read(a,b);
  var S1:=FS(a,b);
  Write('Катеты второго треугольника: '); Read(a,b);
  var S2:=FS(a,b);
  if S1>S2 then Writeln('Площадь первого треугольника больше')
  else
    if S1<S2 then Writeln('Площадь второго треугольника больше')
  else Writeln('Площади треугольников равны')
end.

Тестовое решение
Катеты первого треугольника: 4.18 6
Катеты второго треугольника: 5.4 3.9
Площадь первого треугольника больше
0,0(0 оценок)
Ответ:
b00777
b00777
08.03.2020 11:22
1. Короткий вариант

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=ArrRandom(10,10,20); a.Println;
  Writeln('Сумма кубов ',a.Select(x->x*x*x).Sum);
  a.Transform(x->x-5); a.Println
end.

Тестовое решение
14 17 12 17 20 11 13 18 19 20
Сумма кубов 46517
9 12 7 12 15 6 8 13 14 15

2. "Школьный вариант"

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
  a:array[1..10] of integer;
  i,s:integer;
begin
  Randomize;
  s:=0;
  for i:=1 to 10 do begin
    a[i]:=Random(11)+10;
    Write(a[i],' ');
    s:=s+a[i]*sqr(a[i])
    end;
  Writeln;
  Writeln('Сумма кубов ',s);
  for i:=1 to 10 do begin
    a[i]:=a[i]-5;
    Write(a[i],' ')
    end;
  Writeln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота