В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kattya100
kattya100
22.03.2022 00:44 •  Информатика

Написать программу на c++
цикл со счетчиком
с клавиатуры вводится n целых чисел a1, a2, …,an.
в процессе ввода чисел выводить на экран следующие суммы: a1+a2, a2+a3, …, an-1+an.
цикл с предусловием
вычислите сумму всех чисел фибоначчи, которые не превосходят заданного натурального числа м.
числа фибоначчи определяются по формулам: f0=f1=1; fi=fi-1+fi-2.
цикл с постусловием
вычислите частичную сумму ряда
s=1 -x^2/2! + x^4/4! - x^6/6! + … .
вычисления прекратите, когда модуль очередного слагаемого станет меньше 0,001. значение x вводится с клавиатуры. проверьте, насколько сумма приблизилась к значению cos(x), x измеряется в радианах.

Показать ответ
Ответ:
Анна3481
Анна3481
25.03.2023 08:34
Для начала задачу нужно решить чисто математически, решения приведены на листочках. 
Поскольку задача школьная, то вариант совпадения точек не рассматривается
Алгоритмического языка не знаю, но поскольку это вариант псевдокода, то думаю алгоритм вполне понятен

алг Круг_по_двум_точкам_и_радиусу(арг действ Ax, арг действ Ay, арг действ Bx, арг действ By, арг действ r)
   дано | A,B,r
   надо | нарисовать окружность
нач
    ввод Ax, Ay, Bx, By, r

    действ dAB = ((Ax - Bx)^2 + (Ay - By)^2)^(0.5) // длина АВ
    действ h = (r^2-dAB^2/4)^(0.5) // высота и длина вектора ОМ

    // М середина АВ
    действ Mx = (Ax + Bx) / 2 
    действ My = (Ay + By) / 2

    //первый круг
    действ Ox = Mx + (Ay - By) * h/dAB
    действ Oy = My - (Ax - Bx) * h/dAB
    нарисовать_круг(Ox, Oy, r)

    //второй круг
    Ox = Mx - (Ay - By) * h/dAB
    Oy = My + (Ax - Bx) * h/dAB
    нарисовать_круг(Ox, Oy, r)
кон
Запишите на алгоритмическом языке алгоритм построения окружности заданного радиуса r, проходящий чер
Запишите на алгоритмическом языке алгоритм построения окружности заданного радиуса r, проходящий чер
0,0(0 оценок)
Ответ:
DashaZhur1752
DashaZhur1752
08.09.2020 05:47

#include <iostream>

int gg(int k, int p, double m)

{

p = (k >= p) ? p : p / k;

return (m * 2 * p);

}

int main()

{

int k, p;

double m;

std::cout << "Сколько котлет можно одновременно положить на сковороду ? ";

std::cin >> k;

std::cout << "Сколько минут жарится одна сторона котлеты ? ";

std::cin >> m;

std::cout << "Сколько котлет вы будете жарить ? ";

std::cin >> p;

std::cout << p << " котлет пожарятся с двух сторон минимум за " << gg(k, p, m) << " минут";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота