В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yanameleshko2016
yanameleshko2016
27.02.2022 08:13 •  Информатика

Написать программу на c++

даны два угла треугольника (в градусах). определить, существует ли
такой треугольник. если да, то будет ли он прямоугольным.

Показать ответ
Ответ:
samat314
samat314
10.10.2020 06:25

#include <iostream>

using namespace std;

int main()

{

 setlocale(LC_ALL, "russian");

 int a, b, c;

 cout << "Введите два угла треугольника в градусах: ";

 cin >> a >> b;

 c = 180 - b - a;

 if (a > 0 && b > 0 && c > 0) {

   cout << "\nТреугольник существует.";

   if (a == 90 || b == 90 || c == 90)

     cout << "\nЭто прямоугольный треугольник.";

 }

 else

   cout << "\nТреугольник не существует.";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота