В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alexey2ristp00z7s
alexey2ristp00z7s
17.05.2020 04:29 •  Информатика

написать программу на C#, которая будет решать данную задачу: Спецслужбы получили информацию о том, что в труднодоступной части Муравийской пустыни расположена хорошо замаскированная база террористов. В руки спецслужб попал и план этой базы, которая с большой высоты выглядит как группа скальных обломков, весьма часто встречающихся среди Муравийских песков. Президент отдал приказ уничтожить базу крылатыми ракетами. Ваша задача - по карте пустыни, полученной со спутника и плану базы определить количество возможных положений базы террористов.
На входе вводятся числа Nb и Mb (1 ≤ Nb, Mb ≤ 20). В следующих Nb строках записан план базы. Каждая из этих строк содержит по Mb символов "#" (ASCII 35) или "." (ASCII 46). Символ "#" обозначает фрагмент базы, а символ "." - песок. В следующей строке записаны числа Nd и Md (1 ≤ Nd, Md ≤ 100). И остаток входных данных содержит карту участка пустыни, на котором, предположительно, находится база террористов - Nd строк по Md символов "#" или "." в каждой.
Пример входных даных:
2 2
#.
##
3 5
#.#.#

.###.

Показать ответ
Ответ:
Neznayka56000
Neznayka56000
25.09.2022 10:20

#include <iostream>

#include <string>

bool is_palindrome(const std::string& s) {

   std::string r(s);

   std::reverse(r.begin(), r.end());

   return s == r;

}

int main() {

   std::string s1,s2;

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите число 1: ";

   std::getline(std::cin, s1);

   std::cout << "Введите число 2: ";

   std::getline(std::cin, s2);

   if (is_palindrome(s1)|| is_palindrome(s2))

       std::cout << "Одно из введенных чисел является палиндромом " << std::endl;

   else

       std::cout << "Ни одно из введенных чисел не является палиндромом " << std::endl;

   return 0;

}

0,0(0 оценок)
Ответ:
sofia308
sofia308
07.06.2020 01:34

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

Объяснение:

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота