В массиве хранится информация об отметках 20 учащихся за контрольную работу (случайные числа от 1 до 10). Составьте программу, которая вычисляет количество учащихся, получивших неудовлетворительные отметки (0, 1, 2).
Детерминированность или стохастичность. Если в модели среди величин имеются случайные, т.е. определяемые лишь некоторыми вероятностными характеристиками, то модель называется стохастической (вероятностной, случайной). В этом случае и все результаты, полученные при рассмотрении модели, имеют стохастический характер и должны быть соответственно интерпретированы. Здесь подчеркнем, что с точки зрения практики граница между детерминированными и стохастическими моделями выглядит расплывчатой. Так, в технике про любой размер или массу можно сказать, что это не точное значение, а усредненная величина типа математического ожидания, в связи с чем и результаты вычислений будут представлять собой лишь математические ожидания исследуемых величин. Однако такой взгляд представляется крайним. Удобный практический прием состоит в том, что при малых отклонениях от фиксированных значений модель считается детерминированной, а отклонение результата исследуется методами оценок или анализа ее чувствительности. При значительных же отклонениях применяется методика стохастического исследования.
Var a,b,c,D,x1,x2:double; begin Write('Введите коэффициенты квадратного уравнения А В С: '); Read(a,b,c); if a=0 then Writeln('А не может равняться нулю: уравнение не будет квадратным') else begin D:=sqr(b)-4*a*c; if D<0 then Writeln('Нет корней') else if D=0 then Writeln('x=',-b/(2*a)) else begin D:=sqrt(D); x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a); Writeln('x1=',x1,', x2=',x2) end end end.
Тестовое решение: Введите коэффициенты квадратного уравнения А В С: 2 -5 3 x1=1, x2=1.5
a,b,c,D,x1,x2:double;
begin
Write('Введите коэффициенты квадратного уравнения А В С: ');
Read(a,b,c);
if a=0 then
Writeln('А не может равняться нулю: уравнение не будет квадратным')
else begin
D:=sqr(b)-4*a*c;
if D<0 then Writeln('Нет корней')
else
if D=0 then Writeln('x=',-b/(2*a))
else begin
D:=sqrt(D);
x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a);
Writeln('x1=',x1,', x2=',x2)
end
end
end.
Тестовое решение:
Введите коэффициенты квадратного уравнения А В С: 2 -5 3
x1=1, x2=1.5