В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)

Показать ответ
Ответ:
Anya2587
Anya2587
11.09.2020 11:24

#include <iostream>

using namespace std;

int main()

{

 int n, i, j;

 string s, c;

 cout << "N = ";

 cin >> n;

 s = string(n, ' ');

 for (i = 1; i <= n; i++) {

   cout << "\n" << s;

   s.erase(s.size() - 1);

   for (j = 1; j <= i; j++) {

     if (n <= 9)

       c = " ";

     else

       c = i <= 9 ? "  " : " ";

     cout << c << i;

   }

 }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота