написать программу на C++
Оформить функцию поиска количества нулевых элементов массива. В главной программе дано 3 одномерных массива arr1,arr2,arr3 длиной 10 элементов каждый. Применить функцию для каждого из 3-х заданных массивов. (в функции не должно быть операторов ввода или вывода)
#include <iostream>
using namespace std;
#define n 10
void fillingMass(int arr[n])
{
for(int i=0; i<n; i++)
{
arr[i] = -5 + rand() % 10;
cout<<arr[i]<<" "; // вывод содержимого массивов, если не надо уберешь
}
cout<<endl; // вывод содержимого массивов, если не надо уберешь
}
int countingZero(int arr[n])
{
int count = 0;
for(int i=0; i<n; i++)
{
if(arr[i] == 0)
count++;
}
return count;
}
int main()
{
int arr1[n],arr2[n],arr3[n];
fillingMass(arr1);
fillingMass(arr2);
fillingMass(arr3);
cout<<"In the first array, the number of zero elements = "<<countingZero(arr1)<<endl;
cout<<"In the second array, the number of zero elements = "<<countingZero(arr2)<<endl;
cout<<"In the third array, the number of zero elements = "<<countingZero(arr3)<<endl;
return 0;
}
Объяснение: