Написать программу на c++. Указать количество учеников, после чего вывести случайное число из этого количества. После чего ученику можно поставить оценку (2,3,4,5) либо же отсутствие (Н). Дополнительные условия.
Сделать ошибку ввода оценки (если вводим число 1 или больше 5). Так же один и тот же номер ученика не может выпадать дважды.
В конечном итоге вывести номер ученика и его оценку (либо отсутствие).
PascalABC.Net
procedure Rad(a: real; n: integer);var R, R2: real;begin R := a / (2 * sin(pi / n)); R2 := R * cos(pi / n); Println('Радиус (Описаный): ', R); Println('Радиус (Вписаный): ', R2);end;begin var a := ReadReal('Введите A: '); var n := ReadInteger('Введите N: '); Rad(a, n);end.Varian 2
program HappyCoder; var R, R2, A: real; n: integer; begin Writeln('Введите A: '); Read(A); Writeln('Введите N: '); Read(n); R := a / (2 * sin(pi / n)); R2 := R * cos(pi / n); Writeln('Радиус (Описаный): ', R:0:3); Writeln('Радиус (Вписаный): ', R2:0:3); end.ответ:1)194 2)110
Объяснение:
1) var s; k: integer;
begin
s:=5;
for k:=1 to 6 do (цикл в котором к становится массивом и заполняется числами от 1 до 6 (1 2 3 4 5 6))
s:=s+9*k; (1. 5+9*1=14 2. 14+9*2=32 3. 32+9*3=59 4. 59+9*4=95 5. 95+9*5=140 6. 140+9*6=194)
writeln(s);
end
2)var s; k: integer;
begin
s:=2;
for k:=6 to 14do (цикл в котором к становится как бы счётчиком для действия ниже)
s:=s+12 (6]2+12=14 7]14+12=26 8]26+12=38 9]38+12=50 10]50+12=62 11]62+12=74 12]74+12=86 13]86+12=98 14]98+12=110)
writeln(s);
end