Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
lakomka2018
17.05.2021 00:26 •
Информатика
Написать программу на c++. условие такого: вычислить сумму ряда, 1-1/2+1/3-1//n. по введенному n нужно посчитать сумму.
Показать ответ
Ответ:
vanyastal2015
15.07.2020 20:24
#include <iostream>
using namespace std;
int main()
{
int n, i, m = 1;
double s = 0.0;
cin>>n;
for (i = 1; i <= n; s += double(m)/i, m = -m, i++);
cout<<s;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
MrLux123
27.07.2020 11:09
По информатике. запустите текстовый редактор...
Млада000
09.02.2020 02:04
Сколько разрядов будет в том числе, если записать его в восьмеричной системе счисления. а) 10111010; (двоичная) б) 1001111000111; двоичная в) a18c(шестнадцатиричная) г) 1375be...
Sultanasem2007
09.02.2020 02:04
По информатике проверить является ли целое число не четным. ....
Annala1
30.05.2021 18:36
:1 d[1..2,1..6] числами 12,32,41,3,4,7,9,19,23,24,27,39 2: t[1..10,1..10] от 6 до 43....
Agetnor
30.05.2021 18:36
Создать массив на четных местах в котором стоят единицы а на нечетных местах числа равные остатку от деления своего номера 5...
momot06
25.03.2023 16:21
Скорость передачи данных через выделенный канал равна 131072 бит/с. передача файла через данное соединение заняла 2 минуты. определите размер файла в килобайтах...
marinichnatash
25.03.2023 16:21
Сколько секунд потребуется модему, сообщение со скоростью 16384 бит/с, чтобы передать сообщение объёмом 356кбайт...
vitusyaischuk
10.01.2023 14:40
Найдите самый маленький натуральный делитель числа х, отличный от 1 (2 =х =30000). входные данные выходится натуральное число выходные данные выведите наименьший делитель числа...
vladlena217
10.01.2023 14:40
Графическое изображение размером 320 400 пикселей занимает 16000 байтов памяти. сколько цветов в палитре...
PRIL82
10.01.2023 14:40
Запишите в паскале a(b-5.8)- ((3.7b)/4) + ((a-b)/2)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int n, i, m = 1;
double s = 0.0;
cin>>n;
for (i = 1; i <= n; s += double(m)/i, m = -m, i++);
cout<<s;
}