В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dianadiii
dianadiii
23.11.2021 06:26 •  Информатика

Написать программу на pascal.это ! найдите и выведите на экран самую большую и самую маленькую цифру в трехзначном числе введенного с клавиатуры. желательно с объяснениями, т.к. в много однотипных . и без "введите число" и т.д.заранее .

Показать ответ
Ответ:
wereweek777
wereweek777
03.10.2020 02:50
Var
    N, a1, a2, a3, min, max: integer;
begin
    readln(N);
    N := abs(N);
    a1 := N mod 10; //в а1 хранится разряд единиц введённого числа
    N := N div 10;     //"стираем" в N последнюю цифру
    a2 := N mod 10; //в а2 хранится рязряд десятков числа N
    N := N div 10;
    a3 := N mod 10; //в а3 хранится рязряд сотен числа N
    //
//поиск минимума из цифр. в переменной мин
//хранится наименьшее число на данном шаге.
    min := a1;          
    if a2 < min then
        min := a2;
    if a3 < min then
        min := a3;
   //
//поиск максимума
    max := a1;
    if a2 > max then
        max := a2;
    if a3 > max then
        max := a3;
    //
    writeln('min - ', min, ' max - ', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота