Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
kostyatar2016
25.11.2022 06:36 •
Информатика
Написать программу на паскале. дано натуральное число. вычислить среднее нечетных цифр.
Показать ответ
Ответ:
dobryninaaleksp08b5v
12.07.2020 12:52
Var n, c, d, p: integer;
begin
readln(n);
p := 1;
while n<>0 do begin
d := n mod 10;
n := n div 10;
if d mod 2 = 1 then begin
p := p * d;
c := c + 1;
end;
end;
if c = 0 then writeln (0)
else writeln(Exp(Ln(p)/c):0:3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
виктория1447
25.08.2022 19:13
Неопасные компьютерные вирусы могут : к сбоям и зависаниям при работе компьютера. к потере программ и данных. к форматированию винчестера. к уменьшению свободной памяти компьютера....
knestor
01.12.2021 09:23
Верно ли утверждение? Числа в римской системе счисления получаются путём сложения или вычитания ключевых цифр....
green121
14.02.2020 20:40
Какие программы предназначены для работы с векторной графикой (несколько) а. Компас3Д б.Photoshop в.Corel Draw г.Blender д.Picasa е.Gimp...
KewaKewka
25.06.2022 01:16
Дано Вектори а(3;2) і в(0;-1). Знайдіть вектор c = 2а+4в та його абсолютну величену....
vipamalia03
08.08.2022 01:47
Задача 2. Найти векторное произведение векторов A(-4;3;0), В(0;1;3),C(-2;4;-2). AB×BC .заранее большое....
KARAZINO
20.02.2020 06:10
НАПИСАТЬ Сообщение о дружбе и друзьях Пушкина....
ntaskaeva2
07.01.2021 21:21
Сообщение «развитие библиотек федерального ведения за последние три года...
baklazhan2004
29.07.2022 02:42
На этой фотографии святитель изображён с...
guljanatkabdrasheva
29.02.2020 12:20
Почему Вакула противен к чёрту противен к чёрту дам 30юалов...
azavidov00
16.09.2022 18:14
ЗА РЕШЕНИЕ И ЗА ОБЪЯСНЕНИЕ КАК СДЕЛАНО...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
readln(n);
p := 1;
while n<>0 do begin
d := n mod 10;
n := n div 10;
if d mod 2 = 1 then begin
p := p * d;
c := c + 1;
end;
end;
if c = 0 then writeln (0)
else writeln(Exp(Ln(p)/c):0:3);
end.