В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yan7772
yan7772
04.07.2021 11:46 •  Информатика

Написать программу на Паскале,используя цикл с постусловием (Repeat-until) для решения задачи. Вычислить сумму всех двухзначных чисел. S=10+2+3+...+99. Сделайте так чтобы мой Паскаль, принял вашу программу

Показать ответ
Ответ:
Alina0989
Alina0989
09.03.2022 16:02

#include <iostream>

using namespace std;

void customFunk(const char *text) {

cout << "+-";

for (int i = 0; i < strlen(text); i++) {

 cout << "-";

}

cout << "-+" << endl;

printf("| %s |", text);

cout << endl << "+-";

for (int i = 0; i < strlen(text); i++) {

 cout << "-";

}

cout << "-+" << endl;

}

int main()

{

customFunk("Hello World!");

return 0;

}

Объяснение:

Самый простой Для модернизации рекомендую убрать циклы и вместо них создать массив char'ов с количеством элементов равному размеру входящего текста и выводить его вместо циклов.


Напишите функцию, которая принимает на вход строку текста и печатает ее на экран в рамочке из символ
0,0(0 оценок)
Ответ:
ILiveYou
ILiveYou
14.01.2022 19:58

Задача 1

program z1;

var n,a,i,k:integer;

begin

write ('Введите количество чисел: ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a);

if a = 0 then k:=k+1

end;

writeln('Количество нулей среди чисел: ',k)

end.

Задача 2

program z2;

var n,a,i,m:integer;

begin

write ('Введите количество чисел: ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a);

if i = 1 then m:=a;

if a > m then m:=a

end;

writeln('Максимальное число среди чисел: ',m)

end.

или

program z2;

var n,i,m:integer;

a:array[1..100] of integer;

begin

write ('Введите количество чисел (n<=100): ');

read (n);

for i:=1 to n do

begin

write ('Введите число: ');

read (a[i]);

if i = 1 then m:=a[i];

if a[i] > m then m:=a[i]

end;

writeln('Максимальное число среди чисел: ',m)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота