В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
mayakmaria
mayakmaria
04.06.2023 06:19 •  Информатика

Написать программу на паскале, которая вводит массив из n целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. протестировать программу для следующих массивов: а) 3 5 -2 0 -6 -8 1 б) -1 -2 -3 0 -1 2 3 массивы должны вводися вручную а не рандомно.

Показать ответ
Ответ:
ts26092004
ts26092004
25.05.2020 08:40

var a: array[1..100] of integer;

n, i: integer;

begin

write('Введите количество элементов массива');

readln(n);

write('Вводите элементы массива отделяя их клавишей "Enter"');

for i:=1 to n do 

read(a[i]);

for i:=1 to n do 

if a[i]<0 then write('число ', a[i], ', номер ', i,'; ' );

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота