В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mariakochmar
mariakochmar
17.12.2022 06:36 •  Информатика

Написать программу на паскале: определить количество строк матрицы, в которых хотя бы один элемент равен t

Показать ответ
Ответ:
оаилпаидшп
оаилпаидшп
17.06.2020 14:03

Program Natasha1925_2;
uses crt;
const n=50;
var
  a:array[1..n,1..n] of integer;
  t:integer;
  i,j,kwo:integer;
  yes:boolean;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  randomize;
  {создание массива}
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          a[i,j]:=random(101)-50;
          write(a[i,j]:7:2);
        end;
      writeln();
    end;
  write('Введите число t: '); read(t);
  {поиск строк}
  kwo:=0;
  for i:=1 to n do
    begin
      yes:=FALSE;
      for j:=1 to n do
        if a[i,j]=t then
          yes:=TRUE;
      if yes then kwo:=kwo+1;
    end;
 writeln('Количество строк: ',kwo);
end.

0,0(0 оценок)
Ответ:
Kseniya05
Kseniya05
17.06.2020 14:03

uses crt;
var
  a:array [1..100,1..100] of real;
  t:real; i,j,k:integer;
begin
  randomize;
  write('Введите количество строк матрицы: '); read(i);
  write('Введите количество столбцов матрицы: '); read(j);
  write('Введите число t: '); read(t);
  clrscr;
  for i:=1 to i do
  begin
    for j:=1 to j do
    begin
      a[i,j]:=random(100)-50;
      write(a[i,j],' ');
    end;
    writeln;
  end;
  k:=0;
  for i:= 1 to i do
  begin
    for j:= 1 to j do
    begin
      if a[i,j]=t then
      begin
        k:=k+1;
        j:=1;
        i:=i+1;
      end;
    end;
  end;
 writeln('Количество строк: ',k);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота