Написать программу на Питоне
Ход слона
Шахматный слон ходит по диагонали. Даны две различные клетки шахматной доски, определите, может ли слон попасть с первой клетки на вторую одним ходом.
Входные данные
Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.
Выходные данные
Программа должна вывести YES, если из первой клетки ходом слона можно попасть во вторую, или NO в противном случае.
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт
Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц
Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)
Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
setlocale(LC_ALL,"russian");
cout << "Введите количество нечётных чисел (до 2000 включительно) ";
int count;
int sum = 0;
cin >> count;
if(count >= 1 && count <= 2000)
{
for(int i = 1; i<=count; i++)
{
if(i%2!=0)
{
if(i!=count) // проверка на то, ставить ли ещё 1 плюс или будет равно
{
cout << i << " + ";
sum=sum+i;
}
else
{
cout << i;
sum=sum+i;
}
}
else
{
if(i!=count)
{
cout << i+1 << " + ";
i++;
sum=sum+i;
}
else
{
cout << i+1;
i++;
sum=sum+i;
}
}
}
}
cout << " = " <<sum;
system("pause");
return 0;
}
Аналогичная программа:
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
setlocale(LC_ALL,"russian");
cout << "Введите последнее нечётное число";
int num;
int a;
cin >> num;
num=num+1;
num=num/2;
num=num*num;
cout << "Итого: " << num;
system("pause");
return 0;
}