В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
au20941
au20941
25.11.2021 01:04 •  Информатика

Необходимо составить программу, для вычисления по формуле: у=7-2*x, если x< 0; y=x-1 если x=0; y=(x+4)*2 если x> 0язык с++30 !

Показать ответ
Ответ:
aasybas
aasybas
11.09.2020 09:54

#include <iostream>

using namespace std;

int main() {

int x;

cin >> x;

if (x < 0) {

 cout << "y=" << 7 - 2 * x << endl;

} else if (x == 0) {

 cout << "y=" << x - 1 << endl;

} else {

 cout << "y=" << (x + 4) * 2 << endl;

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота