В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
JustKotOneLove
JustKotOneLove
16.10.2021 07:28 •  Информатика

Написать программу на С. Нужно написать программу, которая вычислит выражения на фото. ​


Написать программу на С. Нужно написать программу, которая вычислит выражения на фото. ​

Показать ответ
Ответ:
vitalinaartikov
vitalinaartikov
17.08.2020 07:48

import random

def magic(n):

   matrix = []

   def sort(array):

       i = 0

       def check(array):

           for j in range(len(array) - 2):

               if array[j] > array[j + 1]:

                   return False

           return True

       while True:

           if array[i] > array[i + 1]:

               max = array[i]

               array[i] = array[i + 1]

               array[i + 1] = max

           i += 1

           if i > len(array) - 2:

               i = 0

           if check(array):

               break

       return array

   def writeMatrix(matrix):

       for arr in matrix:

           print(arr)

   for row in range(n):

       matrix.append([])

       for column in range(n):

           matrix[row].append(random.randint(-50, 50))

   print("Non sorted")

   writeMatrix(matrix)

   print()

   print()

   for arr in matrix:

       arr = sort(arr)

   print("Sorted rows")

   writeMatrix(matrix)  # sorted rows

   column = []

   for arr in matrix:

       column.append(arr[0])

   column = sort(column)

   for j in range(len(column) - 1):

       matrix[j][0] = column[j]

   print()

   print()

   print("Full sorted")

   writeMatrix(matrix)  # sorted rows and columns

def main():

   n = int(input())

   magic(n)      

main()

0,0(0 оценок)
Ответ:
2345tgbkl
2345tgbkl
17.08.2020 07:48

Приложение принимает на ввод информацию о Именах и Фамилиях программистов, а также используемом языке и позволяет найти среди записей информацию о программистах C++.

Иллюстрации кода и тестовых ввода-вывода прикреплены во вложениях.

Ваши оценки и отзывы позволяют лучше оценить решение.

Если ответ удовлетворил, отметь его как "Лучший".

Успехов в учёбе!

Код:

#include <iostream>

#include <string>

#include <utility>

#include <vector>

#include <exception>

struct Coder {

   std::string name;

   std::string lastname;

   std::string language;

   Coder(std::string name, std::string lastname, std::string language) :

       name(std::move(name)),

       lastname(std::move(lastname)),

       language(std::move(language))

   { }

   explicit operator std::string() const

   {

       return name + " " + lastname + " " + language;

   }

};

struct DataBase {

private:

   std::vector<Coder> _base;

public:

   bool add_coder(Coder coder) {

       _base.push_back(std::move(coder));

       return true;

   }

   std::vector<Coder> search_by_language(const std::string& language_name) {

       std::vector<Coder> search_results;

       for(auto & coder : _base) {

           if (coder.language == language_name) {

               search_results.push_back(std::move(coder));

           }

       }

       return search_results;

   }

};

int main() {

   DataBase base;

   std::cout << "Please enter information about programmers like this \"Bjarne Stroustrup C++\" bellow" << std::endl;

   std::cout << "You can type .find command for finding all added programmers who have developed with C++" << std::endl;

   std::string input, name, lastname, language;

   while(true) {

       std::cout << "> ";

       std::cin >> input;

       if(input == ".find") break;

       name = input;

       std::cin >> lastname >> language;

       base.add_coder(Coder(input, lastname, language));

   }

   std::vector<Coder> search_results = base.search_by_language("C++");

   for(auto & search_result : search_results){

       std::cout << (std::string)search_result << std::endl;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота