В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
JackFollower
JackFollower
13.09.2021 04:14 •  Информатика

написать программу на visual basic Вывести первое число, если оно меньше второго, и оба числа, если это не так

Показать ответ
Ответ:
мак189
мак189
17.10.2020 04:53

Пример на языке с++, дошел только для этого

#include<iostream>

using namespace std;

int min(int a, int b, int c, int d)

{

 int min1 = 0;

 int min2 = 0;

 if (a < b)

 {

  min1 = a;

 }

 else

 {

  min1 = b;

 }

 if (c < d)

 {

  min2 = c;

 }

 else

 {

  min2 = d;

 }

 if (min1 < min2)

 {

  cout << "Наименьшее из чисел: " << min1 << endl;

 }

 else

 {

  cout << "Наименьшее из чисел: " << min2 << endl;

 }

 return 0;

 

 

 

 

}

int main()

{

setlocale(LC_ALL,"RUSSIAN");

min(10,20,30,40);

 

return 0;

 

}

0,0(0 оценок)
Ответ:
Dinkaakissa20
Dinkaakissa20
23.09.2022 09:46

using System;

using System.Linq;

namespace task29760750

{

   internal class Program

   {

       private static void Main(string[] args)

       {

           var N = int.Parse(Console.In.ReadLine());

           var array = Console.In.ReadLine()

               .Split(' ')

               .Select(int.Parse)

               .ToArray();

           var X = int.Parse(Console.In.ReadLine());

           var indices = array

               .Select((t, i) => t == X ? i : -1)

               .Where(t => t > 0)

               .ToArray();

           Console.Out.WriteLine(indices.Any() ? string.Join(" ", indices) : "-1");

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота