В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yuniman
yuniman
12.09.2022 04:15 •  Информатика

Написать программу на ямк для вычисления значения х по формуле : х=3*а²+4*а*в- 5*с³ ( с объяснением)

Показать ответ
Ответ:
Sofia1863
Sofia1863
18.02.2021 02:51
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin;
  var s:=ReadInteger('n=').ToString;
  If s.Length<>(s.Distinct.Count) then Writeln('не является')
  else
    if s=s.ToCharArray.SortedDescending.JoinIntoString('')
    then Writeln('является') else Writeln('не является')
end.

Примеры
n= 9875431
является

n= 9753321
не является

n= 9763421
не является

Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.
0,0(0 оценок)
Ответ:
Vainax
Vainax
21.10.2021 07:40
Приоритете операций:
! инверсия значения
& побитовое И 
^ исключающее ИЛИ
| побитовое ИЛИ

13(10)=00001101(2)
14(10)=00001110(2)
17(10)=00010001(2)
19(10)=00010011(2)
22(10)=00010110(2)

19 & 17 = 00010011 & 00010001 = 00010001
19 & !17 = 00010011 & 11101110 = 00000010
(19 & 17 | 19 & !17) = 00010001 | 00000010 = 00010011

!19 & 17 = 11101100 & 00010001 = 00000000
(19 & 17 | !19 & 17) = 00010001 | 00000000 = 00010001
17 & 14 = 00010001 & 00001110 = 00000000
(17 & 14 | (19 & 17 | !19 & 17)) = 00000000 | 00010001 = 00010001

22 & 14 = 00010110 & 00001110 = 00000110
(22 | 22 & 14) = 00010110 | 00000110 = 00010110

(17 & 14 | (19 & 17 | !19 & 17)) & (22 | 22 & 14) = 00010001 & 00010110 = 00010000

14^(19 & 17 | 19 & !17) = 00001110 ^ 00010011 = 00011101
14^(19 & 17 | 19 & !17) ^ 13 = 00011101 ^ 00001101 = 00010000

(17 & 14 | (19 & 17 | !19 & 17)) & (22 | 22 & 14) ^ 13 = 00010000 ^ 00001101 = 00011101

14^(19 & 17 | 19 & !17) ^ 13 | (17 & 14 | (19 & 17 | !19 & 17)) & (22 | 22 & 14) ^ 13 =
00010000 | 00011101 = 00011101
00011101(2) = 16+8+4+1 = 29(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота