В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Vovanik212
Vovanik212
02.02.2022 19:31 •  Информатика

Написать программу на языке pascal палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево. рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля). например, числа 121 и 1331 являются палиндромами, а число 123 — нет. по данному числу n найдите n-e в порядке возрастания число-палиндром. программа получает на вход одно натуральное число n, не превосходящее 100 000. программа должна вывести одно натуральное число — n-е в порядке возрастания число-палиндром. пример входных и выходных данных ввод 20 вывод 111

Показать ответ
Ответ:
Лисёнок335
Лисёнок335
04.10.2020 03:55
Var
  s: string;
  n,m: integer;

 begin
  readln(n);
  if (n <= 9) then write(n)
  else if (n <= 9 + 9) then
     begin
       s := inttostr(n - 9);
      write(s + s);
     end
  else if (n <= 9 + 9 + 90) then
     begin
       s := inttostr(n - 9 -9 + 10 -1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90) then
     begin
       s := inttostr(n - 9 - 9 + 90 + 10 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 + 100 - 1);
       m:=s.Length-1;
write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 + 100 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1 );
       write(s + s[::-1]);
     end
  else
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота