В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.
var n,s,t,i:integer; begin Write('Укажите количество данных: '); Read(n); Writeln('Теперь вводите данные'); s:=0; for i:=1 to n do begin Read(t); s:=s+t end; Writeln('Средняя температура за месяц составила ',s/n:0:1) end.
Пример решения
Укажите количество данных: 11 Теперь вводите данные 27 29 26 31 24 23 27 30 31 28 25 Средняя температура за месяц составила 27.4
1) (1 & 0 ∨ 1) ∨ 0 = 1
2) 1 ∨ 0 ∨ (1 & 1) = 1
3) (0 ∨ 1) & 1 = 1
4) 0 ∨ (1 & 1) & 1 = 1
5) ((1 & 0) ∨ (1 ∨ 1)) & (0 ∨ 1) = 1
Объяснение:
1) (1 & 0 ∨ 1) ∨ 0 = (0 ∨ 1) ∨ 0 = 1 ∨ 0 = 1
2) 1 ∨ 0 ∨ (1 & 1) = 1 ∨ 0 ∨ 1 = 1 ∨ 1 = 1
3) (0 ∨ 1) & 1 = 1 & 1 = 1
4) 0 ∨ (1 & 1) & 1 = 0 ∨ 1 & 1 = 0 ∨ 1 = 1
5) ((1 & 0) ∨ (1 ∨ 1)) & (0 ∨ 1) = (0 ∨ 1) & (0 ∨ 1) = 1 & 1 = 1
Общий порядок действий:
1) скобки
2) НЕ (¬, черта над выражением) - значение противоположно исходному высказыванию
3) И (&) - истинно, когда оба исходных высказывания истинны
4) ИЛИ (∨) - ложно, когда оба исходных высказывания ложны
var
n,s,t,i:integer;
begin
Write('Укажите количество данных: ');
Read(n);
Writeln('Теперь вводите данные');
s:=0;
for i:=1 to n do
begin
Read(t);
s:=s+t
end;
Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.
Пример решения
Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4