В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
оаосов
оаосов
30.07.2021 08:47 •  Информатика

Написать программу на языке pascal ! задана окружность с центром в точке о (x0, y0) и радиусом r0. определить пересекается ли заданная окружность с осью абсцисс, если пересекается найти точки пересечения.

Показать ответ
Ответ:
Меруерт999
Меруерт999
02.09.2020 10:19

var x0, y0, r0, x1, x2:real;

begin

readln(x0,y0,r0);

// уравнение окружности: (x-x0)^2+(y-y0)^2=r0^2

if r0*r0-y0*y0>=0 then

begin

x1:=-sqrt(r0*r0-y0*y0)+x0;

x2:=sqrt(r0*r0-y0*y0)+x0;

writeln('Точки пересечения: x1 = ',x1:4:2,' x2 = ',x2:4:2);

end

else writeln('Не пересекается');

end.

Пример:

1 1 2

Точки пересечения: x1 = -0.73 x2 = 2.73

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота