В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
565765g
565765g
05.06.2023 22:14 •  Информатика

Написать программу на языке Pascal. Занесите информацию о десяти европейских странах в массивы. Найдите максимальную численность населения Вот страны:Россия, США, Греция, КНР, Турция, Германия, Испания, Колумбия, Бразилия, Египет

Показать ответ
Ответ:
1660044
1660044
16.02.2021 21:14

Плотность, я так понимаю, населения на квадратный километр? Взял инфу из Wiki. Вот что получилось:

program HomeWork;

const countries:array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');

const density:array[1..10] of real = (8.56,32,81,650,100,230,92,39,23.6,80);

var i:integer;

var d:real;

var s:string;

begin

   d := 0;

   for i := 1 to length(density) do

       begin

           if d < density[i] then

               begin

                   d := density[i];

                   s := countries[i];

               end;

       end;

   writeln('Самая большая плотность в ', s, ', и она равна ', d:3:0, ' человек на квадратный километр')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота