Написать программу на языке паскаль для решения . с цикла с послеусловием напишите программу, которая требует у вас пароль, например, 111. если пароль правильный, то заполняет все строки экрана сообщением «молодец». если после пятой попытки пароль все равно неверен, выходит из программы. для проверки подготовить код программы и результаты ее работы.
program raf105;
const pass = 105;
var enterpass, x:integer;
begin
repeat
write('Введите пароль: ');
readln(enterpass);
if enterpass = pass
then
while 1=1 do
writeln('Молодец')
else x += 1;
until x=5;
end.
Результаты работы программы:1.Вывод: Введите пароль:
Ввод: 105
Вывод: Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец...
2.Вывод: Введите пароль:
Ввод: 123
Вывод: Введите пароль:
Ввод: 106
Вывод: Введите пароль:
Ввод: 0
Вывод: Введите пароль:
Ввод: 104
Вывод: Введите пароль:
Ввод: 666