В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
stepankachan
stepankachan
31.05.2023 09:19 •  Информатика

Написать программу на языке паскаль. с клавиатуры вводятся несколько натуральных целых чисел. необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел. например: вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14

Показать ответ
Ответ:
Мухлисуллин
Мухлисуллин
06.10.2020 04:18
Var
  n, m, p, k, sum, x: integer;
  s: string;
  c, i: byte;

begin
  write('Число: ');
  read(n);
  m := n;
  k := 0;
  while m <> 0 do
  begin
    p := m mod 10;
    K := K + 1;
    m := m div 10;
  end;
 
  Str(N, s);
  c := 0;
  for i := 1 to Length(s) do
    if s[i] in ['0', '2', '4', '6', '8'] then
      Inc(c);
 
  x := n;
  sum := 0;
  while (x <> 0 ) do
  begin
    sum := sum + (x mod 10);
    x := x div 10;
  end;
 
  writeln('Количество чисел: ', k);
  writeln('Количество четных чисел: ', c);
  writeln('Cумма чисел : ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота