В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
yarovikova1981
yarovikova1981
30.01.2022 02:44 •  Информатика

Написать программу на языке С++ для создания динамического массива A[N] , заполнить массив с генератора случайных чисел (получение случайного числа в интервале [a,b] оформить как функцию (а=-30,b =30)). Полученный массив перезаписать удалив из него все нечетные числа.
Перезапись оформить как функцию.

Показать ответ
Ответ:
kamilamirov777
kamilamirov777
05.11.2022 12:16

Создание документа

CTRL+N

Открытие документа

CTRL+O

Закрытие документа

CTRL+W

Разделение окна документа

ALT+CTRL+S

Сохранение документа

CTRL+S

Завершение работы с Word

ALT+F4

Поиск текста, форматирования и специальных элементов

CTRL+F

Повтор поиска

ALT+CTRL+Y

Замена текста, форматирования и специальных элементов

CTRL+H

Переход к странице, закладке, сноске, таблице, примечанию, рисунку и т. п.

CTRL+G

Возврат к странице, закладке, сноске, таблице, примечанию, рисунку и т. п.

ALT+CTRL+Z

Прокрутка документа

ALT+CTRL+HOME

Прерывание действия

ESC

Отмена действия

CTRL+Z

Повтор действия

CTRL+Y

В режим разметки

ALT+CTRL+P

В режим структуры

ALT+CTRL+O

В обычный режим

ALT+CTRL+N

0,0(0 оценок)
Ответ:
кококо23
кококо23
17.01.2023 20:15
На паскале, если не на паскале нужно, то укажите какой необходим.

const m = 5;
         n = 4;
var i, j, max: integer;
     a: array[1..m, 1..n] of integer;
begin
  writeln('Исходный массив: ');
  for i := 1 to m do begin
    for j := 1 to n do begin
      a[i, j] := random(20);
      write(a[i, j]:3);
      if(a[i, j] > max) then max := a[i, j];
    end;
    writeln;   
  end;
  writeln('Максимальный элемента: ', max);
  writeln('Конечный массив: ');
  for i := 1 to m do begin
    for j := 1 to n do begin
      if(a[i, j] mod 2 = 0) then a[i, j] := max;
      write(a[i, j]:3);
    end;
    writeln;
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота