В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
masha32434
masha32434
03.08.2022 15:57 •  Информатика

Написать программу на языке с++(желательно в компиляторе shell c++)

заполнить массив случайными числами в интервале [-100; 100] и переставить все элементы так, чтобы все положительные элементы стояли в начале массива, а все отрицательные и нули - в конце массива. вычислите количество положительных элементов.

решите, надо!
заранее

Показать ответ
Ответ:
nazlygulsayapo
nazlygulsayapo
02.05.2023 13:40

var

   n, i, aon_i, k: integer;

   f: boolean;

function AmountOfNumbers(n: integer): integer;

var

   s: integer;

begin

   s := 0;

   while n > 0 do

   begin

       s := s + n mod 10;

       n := n div 10;

   end;

   AmountOfNumbers := s;

end;

begin

   readln(n);

   

   for i := 0 to n do

   begin

       f := true;

       aon_i := AmountOfNumbers(i);

       

       for k := 2 to 9 do

           f := f and (aon_i = AmountOfNumbers(k * i));

       if f then writeln(i);

   end;

end.

Объяснение:

0,0(0 оценок)
Ответ:
Viktoriya24101
Viktoriya24101
15.01.2020 22:11

pascal

Объяснение:

var

 a: array [1..21] of integer;

 i, max, imax: integer;

begin

 randomize;

 WriteLn('Исходный массив:');

 for i := 1 to 21 do

 begin

   a[i] := random(66) - 13;

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 1:');

 for i := 1 to 21 do

 begin

   if i mod 2 = 0 then a[i] := -3 * a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 2:');

 for i := 1 to 21 do

 begin

   if a[i] < 10 then a[i] := - a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 max := -13;

 WriteLn('Результат задания 3:');

 for i := 1 to 21 do

 begin

   if abs(a[i]) > 40 then a[i] := a[i] - 15;

   Write(a[i], ', ');

   if a[i] > max then

   begin

     max := a[i];

     imax := i;

   end;

 end;

 WriteLn;

 a[imax] := sqr(imax);

 WriteLn('Результат задания 4:');

 for i := 1 to 21 do

   Write(a[i], ', ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота