В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ЛалKа228
ЛалKа228
24.04.2021 01:40 •  Информатика

Написать программу на языке си дано число х в 10 системе счисления. перевести его в систему счисления с основанием n

Показать ответ
Ответ:
Asoooollll
Asoooollll
05.10.2020 22:28
#include<iostream>
#include<string>
using namespace std;

int main()
{
    int x,n;
     string S;
     cout << "x = ",cin >> x;
     cout <<"n = ",cin >> n;
    while(x / n > 0){
        cout <<x / n<<" "<<x % n<<"\n";
        S = (char)(x % n<10?x % n+'0':x % n+'A'-10)+S;
        x = x / n;
        }
    if(x!=0){S = (char)(x<10?x+'0':x+'A'-10)+S;}
    cout <<"x_n = "<<S<<"\n";
     system("Pause");
     return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота