В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Анечка1611
Анечка1611
01.02.2022 22:16 •  Информатика

Написать программу нахождения суммы и произведения всех трехзначных чисел кратных 3!

Показать ответ
Ответ:
lotosalla1
lotosalla1
09.06.2020 16:58

program raf105;

var i,sum,pro,a:integer;

begin

writeln('Вводите 5 чисел по очереди');

pro:= 1;

 for i:=1 to 5 do

 begin

  readln(a);

  if (a>=100) and (a<=999) and ((a mod 3)=0)

    then

    begin

    sum+= a;

    pro*= a;

    end;

  end;

writeln('Сумма трёхзначных  чисел кратных трём: ',sum);

writeln('Произведение трёхзначных  чисел кратных трём: ',pro);

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота