Написать программу, напишите алгоритм на паскале нахождения площади треугольника. если в треугольнике вписана окружность. стороны треугольника вводятся пользователем по (подсказка: в любой треугольник можно вписать окружность только одну. площадь треугольника равна произведению его полупериметра на радиус вписанного в него окружность)
Інструменти для візуалізації
Це зовсім не новина, що сьогодні ми живемо і працюємо в умовах лавиноподібного поширення інформації. І коли нам доводиться обговорювати ці величезні обсяги відомостей у навчальних аудиторіях, під час професійних семінарів чи, зрештою, представляти їх як результати власних чи спільних наукових досліджень, важливо подбати про те, щоб до людям по-справжньому глибоко зрозуміти значення зібраної інформації. Саме тут можуть стати у пригоді інструменти для візуалізації даних, завдяки яким креативно та ефективно можна і виокремити головне, і з різних сторін висвітлити весь контекст.
Якщо Ви готові глибше зануритися у світ візуалізації, то Вас може зацікавити огляд найкращих онлайн-курсів від найкращих відкритих освітніх платформ. А розпочати рекомендуємо з курсу «Візуалізація даних» Анатолія Бондаренка, засновника http://texty.org.ua, на «Prometeus».
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
// Variables
double a = 0, b = 0, c = 0;
double x;
double condition;
double sub_condition;
double y;
// Input
cout << "Input numbers:" << endl;
cout << "a = ";
cin >> a;
cout << "b = ";
cin >> b;
cout << "c = ";
cin >> c;
cout << "x = ";
cin >> x;
// Create condition
condition = abs(1 - pow(x, 2));
sub_condition = a + c;
// Solution
if (condition == sub_condition) {
y = sqrt(abs(a * x - pow(cos(pow(b, 3)), 2) * x + 5.1 * pow(c, 2)));
}
else if (condition > sub_condition) {
y = exp(0.04 * x) + log(pow(b, 5) * cos(x));
}
else {
y = pow(cos(pow(b, 3) * pow(x, 2)), 2) + log(abs(b * x - pow(a, 2)));
}
cout << "Answer: y = " << y << endl;
return 0;
}