В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
katya8998
katya8998
03.10.2021 14:32 •  Информатика

Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). r1 и r2 соответственно радиусы внутренней и внешней окружностей, образующих кольцо.

Показать ответ
Ответ:
Maxa2511
Maxa2511
02.10.2020 04:12
Var  x,y,r1,r2:real;
begin
write('Введите x, y, внутренний радиус, внешний радиус: ');
readln(x,y,r1,r2);
if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then
  writeln('Да, принадлежит')
  else writeln('Нет, не принадлежит');
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота