В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
BooHazz
BooHazz
14.07.2021 08:22 •  Информатика

Написать программу, от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

Показать ответ
Ответ:
azamaaaaa
azamaaaaa
16.09.2020 10:48
В григорианском календаре високосным является:
- год, номер которого делится нацело на 400
- год, номер которого делится на 4, но не делится на 100
Программа на паскале:
var n: integer;
begin
  read(n);
  if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)
  then writeln(n, ' год високосный')
  else writeln(n, ' год невисокосный');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота