В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Васяян
Васяян
06.03.2020 15:25 •  Информатика

Написать программу по информатике! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. верно ли, что все элементы последовательности равны между собой?

Показать ответ
Ответ:
emil132
emil132
05.10.2020 10:56
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
  a.Println;
  if a.Where(x->x>=0).Distinct.Count>1 then
    Writeln('Есть отличающиеся элементы')
  else Writeln('Все элементы равны')
end.

Примеры
Длина последовательности:  4
1 1 1 -1
Все элементы равны

Длина последовательности:  5
0 1 1 0 -1
Есть отличающиеся элементы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота