Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
he11sp0re
30.05.2021 08:53 •
Информатика
написать программу подсчета количества всех четных членов массива и произведения чисел, кратных семи этого массива
Показать ответ
Ответ:
Максуд22861827
11.03.2021 00:23
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
dashanarmania
25.05.2022 00:19
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mingazovn
17.05.2021 15:15
Информатика. 6 класс страница 140 Выполняем в тетрадях Напишите название окон в тетрадях....
ashklyarukovpp94
08.06.2023 10:12
После того как загрузится программа MS Paint, на экране появится окно. Выбери то место на картинке, где размещены все доступные меню. Картинка есть....
vasikstrowb
23.08.2022 21:34
7. Складіть проект у середовищі Scratch 2, у якому виконавець намалює три квадрати різних кольорів зі сторонами 100 кроків,якщо до нього доторкається вказівник миші.А також...
djezhik
15.03.2020 08:17
с решением задачи Задача №3 В комнате 15×10 устроена раздевалка. Вдоль левой стены есть свободный проход. К правой примыкают перегородки длиной по 9 клеток. На этих перегородках...
Evgenn4ik
26.07.2020 13:38
быстрее это на 21.04.2021...
StasKir
03.12.2020 01:49
Задача 1.* Родина із трьох чоловік — батьки та дитина 12 років — планує подорожувати до різних міст України. Потрібно визначити, подорож яким транспортом буде дешевшою — потягом...
Messi1444
11.04.2020 08:48
Установи соответствие. Использованиедатчикаосвещённости вусловий циклаРис. 1УказаниебесконечногоВыполненияциклаРис. 2Использованиедатчика цвета вусловий циклаРис. 3ТОИспользованиедатчика...
Trifonova252525
16.09.2020 17:37
19) Напишите программу на python, которая ищет среди целых чисел, принадлежащих числовому отрезку [118811; 118972], числа, имеющие ровно 6 различных делителей. Выведите эти...
theaziimut
04.09.2021 21:36
Напишите наибольшее целое число Х,для которого истинно высказывание: НЕ (Х 8) и НЕ (Х =14)...
ebusuruna
04.05.2021 05:01
Вводится последовательность целых ненулевых чисел, признак окончания ввода – ввод 0. определить является ли последовательность возрастающей. Pascal ABC...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.